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THEME: REVERSE ENGINEERING OF MACHINE PART BY PARAMETRIC MANNER 

ABSTRACT 

This thesis deals with developing a methodological process for reverse engineering of machine 

parts with parametric surfaces. Real part is digitized with 3D scanner and obtained digital data 

is processed to create 3D solid model. Solid model is utilized to generate NC program and 

manufacture new part in CNC machining centre. The new part is compared with the original 

model and results are discussed. 
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TÉMA: REVERZNÍ INŽENÝRSTVÍ STROJNÍ SOUČÁSTI PARAMETRICKÝM 

ZPŮSOBEM 

ANOTACE 

Tato diplomová práce se zabývá návrhem metodického postupu reverzního inženýrství strojní 

součásti obsahující parametrické povrchy. Reálný díl je digitalizován pomocí 3D optického 

skeneru a získaná digitální data jsou zpracovávána. Je vytvořen 3D objemový model, který je 

využit pro generování NC programu a výrobu nové součásti na CNC obráběcím centru. 

Vyrobený díl je porovnán s původním modelem a výsledky jsou diskutovány. 

KLÍČOVÁ SLOVA 

Reverzní inženýrství, ATOS II 400, Polygonální síť, Geomagic DESIGN X, Objemový model, 
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1. INTRODUCTION 

Engineering is mathematical and scientific fundamentals implemented in designing, 

manufacturing, operating and maintaining. Conventional engineering is the process of 

transforming engineering concept or models into real parts. The procedure of producing a 

desired part is called as forward engineering. The traditional method is complicated in the case 

where there is no existing CAD model for the target part need to be produced. Reverse 

engineering methodology is the solution for making 3D model of a part when it is not having 

an original documentation. Reverse engineering is defined as the process of reproducing an 

existing component by capturing the physical dimensions. In some case reverse engineering is 

important where inspection and improvement are required to construct a new part. Industrial 

needs on reverse engineering process is getting popular day by day. In many areas of industry 

reverse engineering is essential idea for creating a new model from existing model containing 

no history. Manufacturing and medical industry practice reverse engineering techniques to 

reduce the time of product development. Military branches utilizes this concept to perform 

inspection tasks that associated with safety. Many research facilitates are benefited with reverse 

engineering. 

The objective of reverse engineering is to generate a digital data from the physical object. 

Reverse engineering procedure starts with measuring an object. The measurement device 

captures raw data from the object and the captured data is interpreted using CAD/CAE/CAM 

techniques to produce a new design. Reverse process by parametric modelling technique is 

unique in reduction of the cost and time as it is based on design intent. Features from the design 

data are defined with parameters. Features managed by the parameters are easily analysed and 

modified by controlling their parameters.  

1.1 Aim of the thesis 

The goal of reverse engineering an object is to successfully generate a 3D CAD model of an 

object that can be used for future modelling of parts. The main aim of the thesis is to design 

and realization of methodological process for reverse engineering of machine part containing 

parametric surfaces. CNC tool is the target part for the experiment. The tool is for parting or 

grooving operation. Old tool holder of the CNC tool need replacement with new tool holder. 

RE procedure is performed for creating a new tool holder for the CNC tool.  
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The target part is digitised to obtain triangulated mesh models. To emphasis the use of this 

project we have chosen optical scanning device for modelling a 3D objects. Optical scanning 

measurement system ATOS II 400 used for digitization. Measurement process is based on 

principles of optical triangulation, photometry and Fringe Projection method. The ATOS II 400 

is able to ensure fast and easy digitisation of measured objects with relatively high resolution 

and precision. In section 2, we discuss methodology of RE followed by the techniques of data 

acquisition in section 3. Later in the sections the processing of acquired data is studied 

considering practical problems to produce a clean data. CAD/CAM software applications to 

work with STL model for generating NC codes and creating CAD model are discussed. Real 

model is captured using ATOS and CAD model is created with Geomagic Design X software. 

EdgeCAM software is utilized to generate numerical codes for developed CAD model. With 

the use of numerical codes, the new tool holder is manufactured in CNC machining centre 

MAZAK INTEGREX. New tool holder is digitized for inspecting with its CAD model. The 

dimensional inspection is carried out with GOM Inspect. Finally, the results of individual steps 

are analysed and stated. Figure 1 illustrates the sequential manner of the thesis work. 

 

 

Figure 1: Sequence of the thesis work 
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2. REVERSE ENGINEERING METHODOLOGY 

Reverse engineering is accomplished in steps such as part digitizing, processing, and CAD 

modelling. Figure 2, which shows the format of RE methodology.  

 

Figure 2: Flow chart of RE methodology 

Reverse engineering process starts with measuring an object to acquire the data from the object 

of interest and this method is known as data acquisition which is the first step of RE. Contact 

and non-contact measurement techniques are involved to measure the object therefore surface 

or solid model can be obtained. The hardware system of data acquisition acquires the point 

cloud of the object and software system transforms the point cloud to virtual representation in 

the computer. Point cloud is a set of 3D points representing the object. Point clouds are used to 

visualize the object in reverse engineering to develop CAD model. Point cloud is received as 

x, y and z coordinates of points of object surface. Point clouds are not directly used in 3D 

applications but converted to mesh model. Mesh model is triangulated model generated by 

connecting the points of the point cloud. This is also known as STL data. Usually, point cloud 

or STL format are used to save the data obtained from the measurement. The second step of 

RE deals with processing the data acquired (point cloud). Processing is referred as cleaning the 

data. Processing of data involves filtering of noise, data smoothing and data reduction. Data 

processing of acquired data is convenient with point cloud or STL format. Data used for 

creating CAD model must be free from noise and it is an important issue to be consider.  
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Segmentation of data is the next step in RE. Segmentation is to logically divide the original 

point into subsets as the data is in the form of dense set of points. It is also the process of 

splitting the triangular mesh into sub-meshes. By the segmentation one can get appropriate 

single surface which contains points or mesh from particular surface. The last step is to create 

a CAD model from the processed and segmented data. The model is designed according to 

application needs. The CAD model can be manufactured using rapid prototyping or CNC. 

Thus, RE can be applied for making new design and analysing the design with existing design. 

 

3. DATA ACQUISITION 

 

Figure 3: Classification of data acquisition techniques 
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Reverse engineering is developed with data acquisition. Data acquisition is performed with 

various techniques as shown in figure 3. Contact or tactile measurement and non-contact 

techniques are the two types involved in measuring the object from which surface or solid 

model is created. These techniques are successful for simple parts but errors arise when parts 

with complex shape is measured. Industries looking for a technique to overcome the errors to 

develop fast and efficient way for modelling the parts. Each data acquisition technique uses 

some mechanism or phenomenon like light, sound, magnetic field for interacting with the 

surface or volume of the object to be measured. Each technique has strengths and weaknesses 

that require the selection of data acquisition system. Data acquisition systems are constrained 

by physical considerations to acquire data from a limited region of an object’s surface. Hence, 

in non-contact technique multiple scans must be taken to completely measure an object. The 

speed of the phenomenon and speed of sensor device are critical for data acquisition. The type 

of sensor selected determines the measured data and accuracy. Data acquisition needs 

appropriate analysis to determine the positions of the points on the objects surface. Techniques 

are selected according to cost, accuracy and time. Sometimes there is a need of skilled worker 

to perform measurements. Following sections deals with the different types of data acquisition 

techniques and how reverse engineering experiments are benefited using these techniques. We 

must also consider the practical issues of data acquisition which is listed out in this section. 

The data acquisition techniques are explained and reviewed discussing practical problems. 

3.1 Contact or Tactile techniques 

Tactile technique is defined as collection of points relative to the other in small or large volume. 

We can see about the tactile techniques and instruments implemented to capture the points from 

the object. 

3.1.1 Manual measurements 

Manual measuring technique was only existing before 50 years to convert physical model to a 

drawing. This technique involves with instruments such as calipers, measuring gages and 

blocks. Key points on surface of an object are identified and x, y, z coordinates are measured 

manually with reference point. The measured points are entered in CAD system. Precision and 

accuracy of measuring device influences accuracy of measurement. Main disadvantage of this 

measurement is for complex parts because the measured points will be about 2000. And this 

method requires more time for data extraction and data entry [1].  

15 



3.1.2 Coordinate measuring machine 

CMM are most popular for capturing points and implementing reverse engineering. CMM are 

required in measurements for high precision, speed and accuracy. Probe with sensing device is 

installed in machine, trigged when it gets contact with the surface. Different types of probe are 

available for specific requirements. A probe test device has been developed to evaluate CMM 

touch trigger probe errors. Repeatability and pre-travel variation are then calculated [2]. 

CMM’s are NC driven. It is programmed to follow the path of the object to be measured. 

Measured points are input into an IGES file from which drawing of object is generated with 

CAD system. Vertical and horizontal CMM are two types. Quality machine can offer easy 

measurements for free-forming surface. Data accuracy of CMM is verified by collecting data 

from free-form surface and surface is improved using RE process [3]. But still it is an issue to 

measure complex and small objects using CMM. The die of inlet of diesel engine is measured 

with CMM and data is acquired using KUM measurement software. This involves stages like 

object digitization, CAD model reconstruction and NC machining. The measured data is 

transformed so that it can be used in a software for the processing. Processed data is used for 

the creation of the die CAD model. When the CAD model of the die is designed, the NC 

machining process planning can generate numerical codes. The die is manufactured by the NC 

machine tool using the available CAD model. Thus, reverse engineering using contact 

measuring method is practically used in design and manufacturing of complex part taking a die 

of inlet of a diesel engine [4]. Fixture design and flexibility of object is significant for the 

accessibility. Geometric complexity increases with increase in number of points to be 

measured. Accuracy of CMM is 0,05 and external factors like temperature, humidity, vibration 

may be hindrance for accuracy of measurements. 

3.1.3 Robotic arm 

Robotic devices are used for tactile measurement by installing a sensing device in the joints of 

its arm. This sensor can determine relative coordinate location with contact on the part. 

MicrosScribe G2X is accurate and affordable 3D measuring device. It is also called as portable 

CMM. Microscribe is a portable metrology tool used to determine point-by-point digital 

measurements. The touch probe of this device is used to trace over the contours of physical 

model and build complex 3D data sets. Accuracy of this metrology device ranges from 0,20 to 

0,25mm.  
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MicroScribe supports many CAD/CAM and 3D graphic imaging applications. With use of 

Verisurf model-based definition software MicroScribe allows part inspection [5]. Reproduction 

of rare Porche 907 castings was achieved by MicroScribe. Using MicroScribe the original part 

is digitized precisely. Later, rhinoceros software is used to generate outside surface of casting. 

Solid Works was introduced to manipulate the surface. Finally, the new model was 

manufactured by CNC machine [6]. Thus, RE process is achieved with Microscribe. The 

possibilities of damage of parts due to the contact is the big disadvantage. 

3.1.4 Electromagnetic technique 

In this technique the physical object is digitized using electromagnetic fields. PATRIOT 

digitizer and developed by the polhemus [7]. The setup consists of electronic unit, source 

emitting magnetic field (magnetic transmitter), stylus for digitizing the surface of the object. 

The stylus is brought to contact with the object which is surrounded by the magnetic field then 

the data is sensed by the electronic unit. Accuracy of the device is 0.48mm. Easy to digitize 

large objects because of the free moving stylus. Cost effective device when compared to CMM 

but suitable for only non-metallic surfaces. 

3.1.5 Sonic technique  

The object is digitized using sonic digitizing technology in this technique. The principle of 

sonic digitizing technology is measuring of time taken for the travel of sound waves from stylus 

(transmitter) to the microphones (receiver). This time is then processed in the computer to 

calculate x, y, z coordinates of the object. Any material can be digitized using this sonic 

method. Even projected image, x-rays, drawings are possible to digitize. Continuous digitizing 

the set of points from the object is difficult.  

3.2 Non-contact techniques 

Non-contact methods use light, sound, magnetic fields to acquire shape from objects. As we 

discussed the tactile method has relatively lower scan speeds than non-contact method 

therefore some measurements are performed using non-contact techniques. Optical methods 

are most popular with relatively fast acquisition rates. This method works using several 

principles such as triangulation, ranging, interferometry, structured lighting and image 

analysis. In this section, the principles of optical methods and devices are stated.  
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3.2.1 Principles 

Triangulation method is projecting a light beam to the object and sensing the reflection of the 

beam by photo sensitive device. It involves with location and angles to calculate points. High 

energy light source is illuminated on the object at specified angle and sensed using camera. 

Usually optical device uses laser as the light source and video camera for capturing. 

Trigonometry principle is applied with known angle and distance to obtain the data points on 

the object relative to the reference plane. Triangulation is very fast in acquiring data points. 

Accuracy depends on resolution of camera and also distance between the object and laser 

device. Longer the distance of the object, lower accuracy in acquisition rates. Principle of laser 

triangulation and scanning procedure are presented in this article [8].  

Structured lightning works on the patterns of light as principle. The light pattern is projected 

on the surface needed to be digitized. The illuminated pattern of light gets reflected back from 

the surface. Reflected light beam is captured as an image using high resolution camera and 

displayed in the computer with use of software. The resultant image analysed for obtaining the 

data points on the surface. Data point is located at the intersection of the light and line of camera 

axis, triangulation procedure is used to calculate the depth [9]. Moire topography and grid 

coded are approach with different light patterns illuminating on the surface. In Moire 

topography the surface is illuminated with light pattern passing through optical grating. Large 

sets of data points are calculated using structured lightning principle but it is complex to 

determine the data points. To increase the speed of collecting an array of data points can be 

achieved by reflecting multiple stripes of light. Structured lightning grid projection with 

different colors of stripes is used in Genex 3D FaceCam System to acquire data points from 

metallic ramp object [10].  

Ranging can be classified according to source utilized. Source can be optical or ultrasonic. Both 

of them works on the same principle as when beam is incident on the surface of the object and 

inspecting the reflected beam to receive range of points. The Points are calculated by knowing 

the phase difference between incident beam and reflected beam.  

Time of flight is the approach with measuring the time taken by the light to reflect from the 

surface and deducing the surface points. Large objects are digitized by optical scanner with 

time of flight principle [11]. Time of flight is used for ultrasonic source to measure time of 

sound beam from the surface of the object.  
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Ranging has higher accuracy than time of flight because of limitations in time sensing devices. 

Interferometry is technique of superimposing electromagnetic waves on the target parts. The 

distance of the source and target part is measured in wavelengths. It is more accurate since 

order of wavelength is in nanometres. 

Image analysis is time consuming method of determining the data points from object of 

interest. In structured lightning, projected patterns are analysed where as in this method stereo 

images of an object are captured from two different views and analysed for coordinate. 

Identification of matching image pixels in the stereo images are tedious. 

3.2.2 Optical 3D scanners 

Optical 3D scanners are device used to collect data about shape and appearance from real object 

in the environment. Collected Data is constructed to develop a digital 3D model in vast 

applications. Scanner results can be in point cloud format. All 3D Scanners works with 

computer software which process the captured data. Many companies produce different kinds 

of 3D scanners with special software packages for reverse engineering, health care, automotive 

industry, aerospace and so on. 3D scanners are categorized according to working principle. 

Laser 3D scanners works with triangulation method and laser is used as a main source to 

project on the surface of the object. Multiple sensors capture’s the reflection from the surface. 

By knowing the distance of the sensor from the laser source and angle of reflected laser light, 

the required points on the surface is generated. Laser 3D scanners are popular for its portability 

and ability to scan shiny surfaces. Laser scanners are can be used for short or long range 

scanning. Laser pulse based and laser shift based scanner are used for scanning large structures, 

aircrafts, buildings. Accuracy of the scanner is ±40 µm and scanning time is 2 seconds [12].  

Structured light 3D scanners project a pattern of light on the object and process the distortion 

in the light pattern. The scanner is positioned according to the geometry of the part and targets 

placed on the object. Calibration of the cameras are performed prior to the scanning. Very high 

resolution, quality of the scanned image is extraordinary because even smallest features from 

the object can be captured. Multiple scans are required in the case of complex objects. Accuracy 

of these scanners are 10 µm. 
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Optically tracked 3D scanners has dynamic referencing which is the ability of the scanner to 

make sure that the device keeps optical track on the object to be measured. This works when 

the targets are placed on the object. Camera can track the object and scan head separately. 

Freedom of movement is an advantage and limitations occur when tracker is not having a clear 

line of sight to the scanner. 

Portable 3D scanners are leading technology in the market at present because of its simplicity, 

greater accuracy, low investment and flexibility. Portable scanners have compact design and 

can be transported so easily. Working principle of these scanners are laser light or structure 

lightning. Advanced portable scanners will acquire half a million points per second to build 

live 3D mesh. Error rises when there is increase in scanning volume. Artec spider 3D scanner 

is a lightweight portable scanner and has an accuracy of 0,03 to 0,05 mm [13]. 

Hybrid 3D scanners are suitable for measuring small to medium sized objects. This type of 

scanners has touch probe fixed to the moving arm. Touch probe is a 3D laser scanner and can 

collect several data points from the object. Base of this scanners are fixed in a table and arm is 

moved over the object to digitize the object. The size of the scanner is very less when compared 

to CMM. Hence CMM can be replaced in certain cases where area of the shop floor is small. 

The FARO Edge ScanArm HD is the most affordable, high performance contact/non-contact 

measurement system and is ideal for product development, rapid prototyping, reverse 

engineering, and 3D modelling of free-from surfaces [14]. 

4. DATA PROCESSING  

Data processing is the major step in transforming scan data to CAD ready file. 3D scan data 

acquired using contact or non-contact technique is a raw data which are not suitable for further 

stages in design. Processing of the raw file is the prime task using special 3D data processing 

software. This section deals with how the 3D scan data is handled and describes usage of 

CAD/CAM software required for reverse engineering. 

4.1 3D scan data 

The target object is scanned to reveal a 3D data points. These points represent the position of 

the target object. 3D scan data is generally in point cloud form and can be transformed into 

mesh/STL by connecting the points creating triangles. Scan data are accurate results of target 

object and used for analysing complex features quickly.  
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4.1.1 Point cloud   

Point cloud is a set of points formed from 3D scanning or measurements. Each point is defined 

by x, y, z coordinates. Position of object is given by each point. When the object is measured 

from multiple views causing the formation of group of points and creating the thickness of the 

model. Point cloud data varies according to the type of device used for measurements. Random 

point cloud data is the output from the CMM and contains points in random position. Grid 

point cloud data is produced by structure light scanners which are easy for mesh data 

transformation. Line point cloud data is difficult for mesh processing and formed by handheld 

scanners. Inspection software requires point cloud with normal information. This information 

is important for calculating the deviations between scan data and nominal data. Point cloud 

with textures are useful for identifying the features which are complex. Point clouds are 

transformed into mesh by mesh processing and NURBS (Non-uniform rational basis spline) by 

surface reconstruction. Point cloud data is efficient for developing a CAD model with long 

range scan data. Quality Inspection, metrology, surveying, visualization and reverse design are 

few applications. Complex engineering objects are extracted from point cloud data [15]. 

4.1.2 Mesh data 

Mesh data is polyhedral based data with poly-face, poly-vertex and poly-edge formed by 

triangulation process. Triangulation is connection of the adjacent points to construct a triangle 

from the point cloud data. STL is a file format of the mesh data is used in rapid prototyping, 

finite element analysis, CNC machining and reverse engineering. Optimization of mesh data 

depends upon the application because uniform triangles are significant for FEM and for 

parametric design it is necessary to have feature information on the mesh data whereas rapid 

prototyping and NC machining requires flawless mesh data. Resolution and size of the data 

depends on the number of triangles in the mesh. Minimum number of triangles in the mesh 

data are ideal for quality results. Triangle density can be changed at particular area in the mesh 

by decimation. Alignment of mesh data with predefined planes makes easier for optimization 

process. Triangle inaccuracies affects the further workflow in reverse design. Hence errors 

formed in the mesh data are removed in the data processing. Non-manifold triangle, crossing 

triangle, reverse triangle and redundant triangle are errors occurring in triangulation process. 

Shape of the triangle is to be considered for the final quality of the mesh data for analysis or 

reconstruction.  
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Aspect ratio of triangle (ratio of width to height) should be adjusted to obtain an equilateral 

triangle shape. Mesh contains some missing data which are filled with triangles during 

optimization. 3D mesh data of scanned object contains dense points with noise from 

acquisition. Noise are in the form of spikes on the mesh and has to be removed to improve the 

mesh. Multiple scan data are available when complex object is digitized. Combining or 

merging is the process of adding multiple scan data. 3D mesh is discretized from the CAD 

model which has a sparse but accurate points. Handling of the sparse mesh data requires new 

algorithm [16]. Mesh data has advantages in feature recognition and volume measurement. 

4.2 Reverse design 

The process of creating a 3D model with information from the scanned data is known as reverse 

design. Parametric and free form are two types reverse design for developing 3D model. The 

scan data needs clean up before the modelling process. Cleaning of scan data alters the 

polygonal faces in mesh and quality of the data is better. Preparation of the scan data is 

according to type of reverse design. 

4.2.1 Parametric reverse design   

 

 

 

 

 

 

 

 

 

 

 

  

 

Figure 4: Workflow of parametric reverse design 
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Parametric reverse design is defined as creating 3D parametric model from the scan data 

Parametric model is developed based on purpose of the design and so the scan data optimization 

is not necessary to be perfect therefore small damage in mesh is acceptable for modelling. 

Feature from the scan data are recognized and extracted to create a parametric feature. The 

feature can be modified by controlling the parameters.  Profile extraction from the scan data is 

the stage of extracting the 2D profile according to the analysed design intent. The required 

profiles are extracted after the segmentation of the scan data. Segmentation operation present 

in reverse design software will split the region into features like plane or cylinder. Extracted 

profiles are used as reference for modelling. Feature Modelling is the next stage which creates 

a 3D model from the extracted profiles. Parametric reverse design can be achieved when the 

designer understands how the target object has evolved. After analysing the features from the 

segmentation regions, reconstruction of the desired feature is completed by extruding or 

revolving the profiles. Final 3D model is exported as CAD file as STEP or IGES format. 

Reverse design approach by extraction of geometrical feature from the scan data to construct 

3D model is known as geometric reverse engineering [17]. Parametric approximation method 

is applied to recover the shape and dimensions from the cam which is taken as a target part 

[18]. Main advantages of this process are to duplicate the target part and enhance the design. 

4.2.2 Free form reverse design 

Creating 3D surface model from the optimized scanned data is known as free form reverse 

design. Surface model is effective while designing outer surface of automobiles and consumer 

products. Surfaces are described with NURBS which are usually used for generating curves 

and surfaces. NURBS are widely used in free form surfaces for handling surface patches and 

representing analytical feature [19]. Free form design depends on the surface of the object. 

Cleaning of scanned data is the first and important step for better quality. Curves are drawn on 

the scanned data for representing the curvature areas and particular area of interest. Next, 

dividing the contours into small areas with square shaped patches.  Approximate equal size of 

patches is responsible for the quality of the free form design. Designer has to draw contours 

such way that it is easier for division of patches. Further division of patches into small squares 

called grids. Finally, combining the surface elements above the grids creates NURBS on the 

surface. 3D surface model can be exported to required file format.  
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Least square method is applied for approximation for creating free form surfaces and reverse 

engineering procedure has been developed [20]. In medical field the customization of parts for 

human body is designed by free form methodology. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 4.1: Workflow of free form reverse design 

4.3 Software 

Computer aided design (CAD) software is the major way for design and modelling of 

components. Computer aided manufacturing (CAM) software is effective in manufacturing the 

components from the 3D model or drawings. The combination of these two systems allows the 

user to transfer the information from design stage to manufacturing stage. In CAD/CAM 

software the data developed in CAD is processed by CAM which generates tool path for 

production of the component. Features of software for generating NC code from STL model 

are described. Special data processing software transforms polygonal mesh into suitable data 

for CAD/CAM software. There are many user friendly software developed for reverse 

engineering that works with scanned data and the best software package is stated.  
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4.3.1 CAM software 

MeshCAM is simple 3D CAM software to work with STL data. Using MeshCAM the tool path 

is created with minimum input and post processor can convert toolpath into any common 

format required by different machines. Cutviewer is a CNC simulator that shows how the 

toolpath looks while machining in CNC. G code from MeshCAM is simulated in cutviewer. 

The working with STL file in MeshCAM has following steps: 

 Import file 

 Define stock 

 Define maximum machining depth 

 Select tool and generate tool path 

 Save tool path and select post processor according to the machine 

MeshCAM is flexible and provides many options for advanced machining. The advantages of 

MeshCAM are works with every 3D CAD program, converts image file (JPG, BMP) into 3D 

surface for direct machining, automatic tool path wizard, calculate the machining area and 

toolpath quickly, complicated parts need fixture for machining and MeshCAM can add support 

to the stock during machining which serves the user to create tool path away from the fixture, 

supports large 3D files. MeshCAM requires third party software for the simulation of the tool 

path which is the main limitation. 5 axis machining functionality is impossible and resolution 

is low when compared to other CAM software. MeshCAM software has been used for 

machining die casting mold from H-13 steel which was successful. MeshCAM users are in 

every field from jewellers to aerospace, machining of ornamental metal parts with MeshCAM 

art which has ability to transform image into 3D surface [21].  

VisualCAM is complete CNC programming software package by Mechsoft used in general 

machining, wood working, molds, dies and tooling. VisualCAM accepts file from any CAD 

systems. One can import STL (ASCII and binary), surface and solid models from IGES, STEP. 

Various CNC manufacturing process is performed with different VisualCAM modules namely 

VisualMILL, VisualTURN, VisualART. VisualMILL – 2.5 ,3,4,5 axis machining functionality 

for programming milling machines. It offers machining technology for free form surfaces and 

solid models with cutting simulation. VisualMill works with solids, surfaces and meshes to 

create machining operation for CNC mills.  
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User can create program by selecting tools from wide options and generate toolpath easily 

according to the part. Final toolpath can be verified by simulation. G-codes are the output 

generated for popular machines in the market from numerous post processor options. The 

typical workflow for machining the part in VisualMILL: 

 Define the machine and post processor 

 Define part, stock geometry, material and work zero 

 Create and select tool for machining 

 Create machining operations with feed rates and cutting conditions 

 Generate the toolpath 

 Simulate the toolpath 

 Post process the toolpath 

VisualMILL is easy to learn with basic knowledge in CAM and its advantages are Automatic 

feature detection, Hole making (Drilling, tapping, boring), Simulation (Toolpath, Cut material, 

machine tool), Holder collision detection, Toolpath editing, Post processor generator. Mold 

and die division of Sugyiama Industries manufacture steel dies for aluminium casting for 

engines and transmission. Sugiyama Industries utilized VisualMILL in production of steel dies. 

Advanced toolpath algorithm was programmed with VisualMILL for machining the die [22]. 

VisualCAM package is benefited by aerospace, automotive, production, architecture because 

of its valued price. 

Edgecam is the best CAM software used in vast application for developing machining 

strategies and generate NC program from solid model as well as STL [23]. The workflow of 

edgecam: 

 CAD - Import solid or STL model 

 CAM - Create machining sequence using edgecam milling, edgecam turning 

 Simulation- Simulate the machining with edgecam simulator 

 Generation – NC program is generator with edgecam command 

Edgecam offers solution for 2.5-axis milling to 4 and 5-axis milling. Generates high quality 

toolpath for complex parts and free form shapes. Edgecam provides machining strategies for 

solid and surface geometry.  
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Manufacturing industries like aerospace, prototyping, moulds are benefited with edgecam’s 

advanced machining cycle that brings optimized tool path control and higher machining 

efficiency. The following are the important features of edgecam: 

 Single machining environment 

 Machine tool and tool path simulation 

 Tool libraries with wide variety of selection 

 Increase machine tool utilization 

 Swarf cutting, 5-axis positioning and finishing 

 Reduced component cycle and programming time 

 Collision checking by avoiding expensive damage to the tool 

 Easy to use graphical user interface 

 Shop floor documentation 

4.3.2 RE Software 

Artec Studio software is professional data processing software acclaimed by the industry. 

Manual mode for highly accurate results by choosing the post processing settings and 

manipulate the data as the user likes. Autopilot mode is the unique technology to get final 

results in easier way by selecting very few options. Autopilot mode is perfect for beginners and 

time saving tool for professionals [24]. 

Leios gives streamlined workflow for RE solution. Leios is fastest route from 3D scanner to 

CAD/CAM suitable for fields like industrial design, engineering and medical. Leios features 

are point cloud optimization, mesh cleaning and modelling, reconstruction by fitting and 

inspection. Sculpting tools in leios is for sculpting directly on the mesh for prototyping and 

enhancing. Integrated directly with recent 3D scanners in the market. Saves time by providing 

one-click function for mesh preparation, fitting and export in STEP format [25].  

Polyworks/Modeler is a comprehensive solution for reverse engineering allowing the 

extraction of curves, parametric sketches, surfaces and prismatic feature from the data of 

digitized part imported in the software. Polygonal model is prepared from the point cloud using 

polygonal editing tools. This software offers intuitive surface and solid modelling approach for 

generating user friendly CAD/CAM model. Real-time quality meshing technology transforms 

digitized part to polygonal model [26]. 
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3DReshaper is the affordable software for processing the 3D point cloud from any digitizing 

device and commonly used in Cultural heritage, architecture and civil engineering. It gives 

powerful functions for handling point cloud such as reduction to keep best points, density 

homogenization, automatic segmentation and noise reduction. Different 3D meshing strategies 

are offered by the 3DReshaper according to the quality of the point cloud. Specific triangle 

reorganization is the feature for better accuracy of shapes in sharp angles and small areas. 

Smoothing, decimation and holes filling are tools available to improve meshes after creation. 

B spline curves from polyline or NURBS surfaces from meshes are computed automatically 

and exported as IGES/STEP file [27]. 

Geomagic Wrap is the post processing software utilizing intelligent and accessible tool for 

converting point cloud into polygonal model. AutoSurface function converts mesh to surface 

model which are exportable as IGES or STEP [28].   

Spaceclaim for reverse engineering is flexible and efficient to work with STL file and clean up 

the scan data. Complex shapes are created quickly as the tools in spaceclaim are easy to learn. 

Manufacturing industries save money and time with this software [29]. 

Verisurf is versatile package for creating mesh from point cloud for analysing the surfaces and 

machining. Automatically create features and planar to develop precise CAD model [30]. 

NX provides reverse engineering solution to rapidly create CAD model from easily importing 

and optimizing the scan data. Rapid surfacing tools can automatically create curves and splines 

to the data for creating CAD geometry. NX helps to accelerate design, simulation and 

manufacturing process [31].  

Geomagic Design X is the comprehensive solution for creating CAD model from real world 

parts faster. CAD users can be familiar with the software because of the remarkable user 

interface. Fully Parametric CAD models and freeform surfaces are created. Single software 

that fulfils data processing, mesh healing and modelling. Using Geomagic Design X 80 % of 

the time can be consumed than traditional surface fitting techniques because the design process 

does not require cleaning of scan data [32]. Massive point cloud processing in Geomagic 

Design X is an innovative feature for visualizing and displaying necessary points from the data. 

Depth, X-ray and height are methods for analysing the complex points clouds. Further the 

points clouds can be selected, edited and modelled.  
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Users are benefited by high quality results with minimum training that are unavailable in other 

RE software. Also innovative solution for design and manufacturing process. Powerful tools 

for achieving the desired model are as follows: 

 Redesign assistant- Extraction of design intensions and parameters from the scan data 

throughout the process of creating a CAD model. Automatic sketching, automatic 

region segmentation and extraction of design parameters from the mesh. 

 Accuracy analyser- Analysis of deviation based on the user defined tolerance for 

comparison of polygonal mesh model with original scan data and analysing geometric 

property such as curvature, continuity, quality. 

 True hybrid modeler- Offers parametric solid modelling with extrude, pipe, sweep and 

revolve. NURBS surfacing with trim/untrim, blend and hybrid modelling process which 

creates parametric model from freeform surfaces.  

 Align wizard- Identifies the coordinate system of the file imported. User can also define 

the coordinate system manually using intuitive coordinate system tool setup. 

 Mesh operations- Class A mesh model is generated instantly for direct use in CAE. 

Advanced mesh operations like global remesh, remove, fit and fix boundary are 

available. 

 Sketch and curve tools- With this highly sophisticated tools, users can extract profiles 

and features from mesh, automatic dimensioning and constraining, 2D drafting, 3D 

curve design. 

 Scan to CAD- Feature wizards and automatic tools allows to extract design directly 

from the scan data by skipping the mesh preparation. 

 Scan to surface- User can create NURBS fittings from the scan data by using automatic 

surface technology or manually too. 

 Scan to mesh- For 3D printing, measurement and polygonal model applications, the 

scan data is processed with mesh Buildup wizard. Scan alignment, merge and 

optimization is achieved in just few clicks. 

 Mesh cleanup- Easy to use mesh cleaning and editing tools for automatic cleaning and 

healing of the mesh. 

 Data transfer- Transfer of the output model with complete history to the CAD 

applications. Export the model in various standard file formats. 
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4.3.3 3D measuring software 

GOM Inspect is the popular 3D measuring software to evaluate data from 3D scanners, CMM’s 

and different types of sources. Major tool for quality control, product development and 

production [33]. The following are the special functions of the software: 

 STL and STEP file can be imported  

 Optimization and generation of polygonal mesh 

 Multiple alignments like pre-alignment, RPS alignment, three points alignment 

 Comparison of mesh data with CAD data 

 GD&T analysis 

 I-Inspect (Intelligent inspection) button allows the user to perform complex inspection 

task 

 Parametric inspection and point-based inspection 

 Reporting module enables to create report, tables, histograms, snapshot and export the 

file to pdf format 

5. APPLICATIONS 

RE methodology is carried out for recovering the damaged part. RE is also applied to recover 

the form and design from the original part. Polygonal model created by processing the scan 

data is exported as STL file and it is compatible for different applications. Rapid prototyping 

is manufacturing of the three dimensional object from the digital model. It is also referred as 

free form manufacturing or layered manufacturing. STL format is the standard data 

transmission format for rapid prototyping. Rapid prototyping is practiced in tool industry for 

manufacturing casting and moulding patterns, prosthetic parts in medical. architecture, fashion 

and sculptors. Computer Numerical Control has a key advantage because the NC programmer 

requires only the geometry of the which is available from STL file. STL file is a closed and 

unambiguous surface suitable for saving errors. Structure of CAD file has some limitations 

especially in small surfaces and requires modelling. STL file do not need any modelling as the 

toolpath relies on the geometry of the part. Finite Element Analysis is the computerized analysis 

technique to visualize the reaction of the manufactured part with physical phenomena. FEA 

make use of mesh generation technique for dividing complex problems into small. STL file of 

the desired part is directly analysed with FEA methods. 
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6.EXPERIMENTAL RESULTS 

This section deals with the complete results of how the target part is digitized, processed, 

manufactured and inspected. RE procedure is suggested by illustrating the individual steps with 

the images. 

6.1 Model 

CNC tool of EMCO turn machine shown in the figure 6 is chosen as real part. Old tool holder 

of the CNC tool need replacement with new tool holder. This is because of the change in 

dimensions of the tool holder. RE methodology is implemented to manufacture the tool holder. 

 

Figure 6: CNC tool 

 

 

Figure 6.1: Old tool holder 
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6.2 Digitizing 

ATOS II 400 is an optical scanner works on principles of optical triangulation, photogrammetry 

and fringe projection. This device is developed by the company called GOM. ATOS system 

ensures fast digitization of the target object with high resolution. It captures surface geometry 

of object in point cloud or polygonal mesh. The main parts of the device are projector, cameras 

and control unit. Light stripes are projected from the projector onto the target object and 

captured by the cameras. ATOS delivers 3D measurement data for manufacturing, automotive 

and widely utilized in several industrial components because of quick data collection and 

accurate 3D measurements. 

 

 

Figure 6.2: ATOS II 400 Scanner 
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Parameters Values 

Weight 5200g 

Dimensions 490 x 260 x 170 mm 

Time of scanning (For one scan) 1 second 

Volume of measurement 250 x 200 x 200 

Number of points measured in one scan Nearly 1,400,000 

Density of point  0,04 – 0,5 mm 

Accuracy of measurement 30 µm 

 

Table 1: Specification of ATOS II 400 

 

ATOS 3D digitizer is controlled and processed by the process-safe software ATOS 

professional to produce precise 3D data. Software is designed to work with ATOS II 400 to 

obtain 3D data from the target object directly after the scanning. Operator is guided by complete 

scanning solution using ATOS professional. Few advantages of this valuable software are: 

 High quality 3D mesh data 

 Measurement and evaluation of dimensions from ATOS 3D data 

 Sensor control, 3D point cloud processing and polygonal mesh generation 

 Automatic calculation of exposure time 

 Industrial measuring solution because it verifies calibration status, transformation 

accuracy, environmental changes and part movement 

 Dynamic referencing 
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Figure 6.3: Operating window of ATOS professional 

Calibration and adjustment of the device is mandatory before the digitization is performed. 

ATOS professional software contains menu bar, tool bar and workspace settings which are 

utilized for calibration settings.  Adjustment and calibration are carried out by following 

procedure: 

 Fitting the camera with appropriate lens  

 Selection of measurement volume  

 Checking the measuring distance from the camera 

 Adjustment of camera in such a way that centre point of projector is same as the centre 

point of the software’s camera and modification of laser pointers. 

 Alteration of sensor settings, projector’s focus, camera’s focus and aperture if required 

Preparation of the target part for digitization is performed after the calibration and adjustment 

of the device.  

 Fixture is selected for the target part and the part is mounted in right position to 

suitable for scanning. Reference points are placed throughout the whole length, 

width and height of the measurement volume.  
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 Reference points are distributed according to certain rules. The target part is applied 

with anti-reflection coating (titanium powder) due to its glossy surface. For this 

process, the part is transferred to another fixture for applying the coating 

 

 

Figure 6.4: Fixture with reference points 

 

Figure 6.5: Target part after the coating 

 The target part is mounted back to the fixture with reference points and kept in the 

rotating table and scanner is set in required position for scanning. Scanning begins with 

stripes of light projecting on the surface of the part. 
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Figure 6.6: Adjustment of scanning position 

 

Figure 6.7: Target part with reference points in ATOS professional 
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 Number of steps and angle of total coverage for the rotation of table are defined to 

perform scanning. 

 

Figure 6.8: Definition of rotation table 

 

 

Figure 6.9: Scanning according to the defined steps and total coverage angle 
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 Reference points are detected by the camera so that data is collected from the part. 

Multiple scans are performed on the target object. ATOS professional combines all the 

scan data into single data. 

 

 

Figure 6.10: Detection of reference points 

 

Figure 6.11: Multiple scan image 
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 The part is turned around and scanning procedure is performed to receive complete 

data. Unwanted parts are selected and removed from the scan data. Calculation of 

polygonal mesh from the scan data is the final step which can be exported in STL 

format. 

 

Figure 6.12: Transformation of reference points 

 

Figure 6.13: Deleting unwanted data 
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6.3 Processing 

Geomagic Design X reverse engineering software is important in the work because solid 

model is created by processing the data of the STL file from ATOS. The shape features are 

extracted from the data to design the tool holder. 

 Import the STL file of the target part by clicking Menu > Insert > Import > STL. 

 

Figure 6.14: Operating window of Geomagic Design X 

 Auto Segment command automatically recogonize 3D feature from the data and 

classifies the region. Click Insert > Region group to initiate Auto Segment. 

 

Figure 6.15: Auto Segment  
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 Align tools are for alignment of mesh data to user defined coordinates. Interactive 

alignment command is useful for manual alignment of mesh data by 3-2-1 and x-y-z 

alignment. Click Tools > Align > Interactive Alignment. Then select the mesh and 

click Next Stage. Select 3-2-1 alignment. Click planar and select region from the data. 

Click Vector and select region perpendicular to the previous. Click Position and select 

region perpendicular to the previous. Click OK. 

 

Figure 6.16: Interactive alignment 

 

Figure 6.17: Alignment of mesh data to reference plane 
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 Mesh sketch mode extracts section polylines from the mesh data and creates 2D 

geometry by fitting polylines. Section polylines are lines or curves from the selected 

section of the mesh data. Click Insert > Mesh Sketch and select Base Plane from the 

mesh data. Then select Method as Planar Method and set value for Offset Distance 

From Base Plane. Click Ok. Planar method extracts section polyline at the intersection 

with defined plane. Sketch mode creates or edits the 2D geometries like splines, arcs 

and lines. The sketch of tool holder is created using sketch mode with required 

dimensions. The section polyline of the tool (mesh data) is utilized for creating the tool 

holder. Click Insert > Sketch and select the base plane to draw the sketch. Click Apply 

and exit Sketch mode. 

 

Figure 6.18: Fitting section polyline 

 

Figure 6.19: Sketch of tool holder 
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 Extrude, revolve, sweep, loft are commands used to generate the solid body from the 

sketch. Click Insert > Solid > Extrude. Select the sketch as base sketch. Select the 

closed profile from the sketch and Specify the Method and Length of extrusion. 

 

 

Figure 6.20: Extrude setup 1 

 

 

Figure 6.21: Extrusion of the profile 1 
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 Following the similar steps stated before for extrusion, closed profiles from the sketch 

of tool holder are extruded. 

 

 

Figure 6.22: Extrude setup 2 

 

 

 

Figure 6.23: Extrusion of profile 2 
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 Mesh Sketch mode is selected to extract the section polyline of the holes from the mesh 

data. Click Insert > Solid > Extrude. Select the Base Sketch, Method, Length. Select 

Flip Direction for changing the direction of extrusion and Cut as Result Operator to 

cut the Holes to the solid.   

 

Figure 6.24: Section polyline of holes 

 

Figure 6.25: Extrusion of holes 
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 Click Insert > Sketch to draw the sketch profile and Insert > Solid > Extrude for 

extrusion of the profile to complete the geometry of the tool holder. 

 

 

Figure 6.26: Sketch profile 

 

Figure 6.27: Extrusion of profile 3 
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 Fillet features are applied for the edges. Export command is for exporting file into 

different file types. Click File > Export. Select required file extension from the dialog 

box. Click OK. The tool holder is exported in STEP file format. 

 

 

Figure 6.28: Export setup 

 

 

Figure 6.29: Final Solid model of tool holder 
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The STL file of the tool from the ATOS professional and STEP file of the tool holder from the 

Geomagic Design X are imported to GOM Inspect software. GOM Inspect is for analysing 3D 

data. In GOM Inspect, the surface of the tool holder (nominal data) which is created from the 

tool (actual data) is compared for checking deviations before the manufacturing process. 

 Click File > Import to select the STL file and STEP file. 

 Select the Tool holder and Click Properties > General and check the Measure 

opposite side box.  

 GOM Inspect contains standard alignment functions. For aligning the tool and the tool 

holder, click Operation > Alignment > Initial Alignment > 3-Point Alignment. 

Select 3 points from the nominal and actual data respectively. Click OK. 

 

Figure 6.30: 3-Point Alignment 

The area on which the tool is having contact with the tool holder is our interest because the 

area was designed by extracting the shape features from the actual data. The tool should be 

fixed perfectly on the edges and so this area is inspected. We can check the deviations of 

the nominal and actual data from the colour map. 
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 Click Operation > Alignment > Main Alignment > Local Best-Fit. Select the 

required area in the actual data and click OK. 

 Click Inspection > CAD Comparison > Surface Comparison On CAD for the results 

of colour map deviations and Click Inspection > Deviation Labels and select the 

region on the CAD for displaying the deviation labels. 

 

Figure 6.31: Surface Comparison on nominal data colour map 1 

 

Figure 6.32: Surface comparison on nominal data colour map 2 
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 Concentricity between holes from the actual and nominal data is checked for deviations. 

Concentricity is selected by clicking I-inspect icon.  

 

 

Figure 6.33: Concentricity check 

The deviations range are from -0.06 to +0.05 in the colour map. Concentricity deviation check 

of holes are minimum 0.08 and maximum 0.12. The inspection results are good to proceed for 

the manufacturing. 

6.4 Manufacturing 

Edgecam software generates machining strategies and NC code from the CAD model. The 

STEP file of the tool holder can be simulated in Edgecam for obtaining the machining tool 

path. Final NC code of the tool holder is given as the input to MAZAK INTEGREX 100-IV 

(CNC machining centre) for manufacturing the new tool holder. The following sequence 

explains the procedure for generating the NC code from STEP file in Edgecam: 

 Loading the tool holder (STEP file) in the Edgecam is the first the step. Click File > 

Open and navigate to the folder with STEP file of the tool holder. 

 Stock is the material shown in Edgecam simulator from which the part is to be 

machined. For creating the stock, Click Geometry > Stock/Fixture and define the 

shape and radius of the stock. Click OK to add stock. 
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 Features are particular shape identified from the model for machining. Click Solids > 

Feature finder. Define the settings in General tab and Mill tab and Click OK. 

 Edgecam allows to access pre-defined tools from ToolStore database. Click Options > 

Preferences and select Tool Libraries tab. Click Modify to open Tool Store 

Administrator and DESKTOP-2HFBK67\ECSQLEXPRESS\Mazak database is 

selected for ToolStore. Click OK. 

 Click CTRL+M for switching to manufacturing mode and creating the Machining 

Sequence. In General tab, define the Machine Tool and define Lathe Setup. 

 

Figure 6.34: Manufacturing mode in EdgeCAM 

 Turning of the stock is the first machining operation. Click Tooling > Tool Store for 

selecting right Turning Tool. Click Turn Cycles > Rough Turn and define Feedrate 

and Speed in General tab. Click OK. Select the desired feature and specify the Start 

and End point of the machining cycle.   

 Milling operations are the next operation in machining. Click Move > Toolchange for 

selecting the appropriate Tool from Mill tab in Tool Store. Click Mill Cycles > Face 

Milling and define Feedrate, Speed, Clearance, Level, Depth, Cut Increment. Click 

OK to select the feature for Face milling. 

 Click Mill Cycles > Flat Land Finishing and define Feedrate, Speed, Clearance, 

Level, Depth, Cut Increment, Lead In, Lead Out and click OK to the select the 

feature. 
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 Click Mill Cycles > Profiling. Define the settings in General, Lead, Depth tabs. Select 

the boundary and specify the start and end point for profiling operation. 

 Drilling operations are performed to drill holes. Click Move > Toolchange to pick Drill 

tool. Click Mill Cycles > Hole to define the Plunge Feed, Speed, Clearance and select 

the feature for drilling. 

 Final operation is Parting off. Click Move > Toolchange and select the Parting Off 

Tool. Click Turn Cycles > Finish Groove to select the feature and define the settings 

in General tab. 

 Machining sequence is simulated in Edgecam. Simulation provides the visual 

machining, check collision of the tool path with the stock, allows to view comparison 

between final machined stock and the original component. Click View > Simulate 

machining and click Start for simulation. 

 Finally, the NC program is generated after creating the machining sequence. Click 

Generate NC icon to open the Generate CNC Code dialog box. Specify the name and 

Click OK for generating the code. 

 

Figure 6.35: Final machined stock in simulation window 
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The NC program which is generated for the new tool holder design is used for manufacturing 

in MAZAK INTEGREX 100-IV with aluminium material. YAMAZAKI MAZAK 

COOPERATION from japan are the producers of Mazak machine. Leading company in 

development of machine tools, Multi-tasking centres and CNC machining centres [34]. 

 

Figure 6.36: MAZAK INTEGREX 100-IV 

 

Figure 6.37: New tool holder 
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6.5 Inspecting 

The New tool holder is digitized with ATOS II 400 optical scanner with the procedure as 

illustrated in the section 6.2 Digitizing. Digitization is performed to obtain STL data of the new 

tool holder.  

 

Figure 6.38: STL data of the new tool holder 

The new tool holder’s STL data from the ATOS and STEP data from the Geomagic Design X 

are imported to the GOM Inspect for inspecting the deviations between actual data and nominal 

data. The area which the tool is on contact with the tool holder is the main interest for the 

inspection. Following are the steps performed in GOM inspect: 

 Import actual and nominal data. 

 Click Operations > Alignment > Prealignment for aligning the actual data with 

nominal. 

 Click Select/Deselect on Surface for selecting the area in which the tool is on contact 

with tool holder. 

 Click Operations > Alignment > Main Alignment > Local Best-Fit. 

 Click Inspection > Surface Comparison on Actual for colour map results. 
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Figure 6.39: Surface comparison on actual data colour map 

 Click Construct > Plane > Fitting plane and select area shown in the figure below for 

creating plane. 

 Click I-inspect icon for checking Flatness on Plane 3 and Parallelism between Plane 

1 and Plane 2. 

 Click Construct > Distance > 2-Point Distance. Select Plane 4 and Plane 5 for 

computing the distance. 

Parameter Nominal 

data 

Actual 

data 

Deviation 

Flatness 0 0.05 0.05 

Parallelism 0 0.01 0.01 

Length 53 52.94 0.06 

Table 2: Results of deviation 
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Figure 6.40: Flatness,parallelism and distance on actual data 

The results from the GOM inspect shows that the design of the new tool holder is safe and final 

stage of inspection is to fix the tool using screws with the new tool holder.  

 

Figure 6.41: New CNC tool holder with the tool 
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7.CONCLUSION 

In theoretical part of the thesis introduction to reverse engineering and its methodology were 

defined briefly. Techniques for acquisition of data was studied with the practical issues. 

Followed by processing of mesh data using parametric and free form reverse design was 

explained. Research of CAD/CAM software applicatons to work with STL model for creation 

of NC program and transformation of polygonal mesh suitable for CAD/CAM was made to 

select the best software. 

The main aim of the thesis was to manufacture a CNC tool holder by RE procedure. So practical 

part of the thesis started with digitizing the CNC tool by ATOS II 400 to receive STL data. 

Geomagic Design X software was the key for the thesis to create solid model of new tool holder 

by parametric manner. EdgeCAM software played major role to generate NC Code using the 

STEP data. The new tool holder was manufacutred using CNC machining centre MAZAK 

INTEGREX. Finally, inspection of actual and nominal data was perfomed in GOM Inspect. 

Thus equipments and software needed for implementing the RE was understood. The procedure 

for RE of parts was practically carried out to manufacture a new part from exisisting part. 

Individual steps of RE process are evaluted to show the suggested RE methodology was the 

best solution. 
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